Not resolved
1.0
Details
Customer service
0 comments

For a week or so before and until the 6th November I was doing a lot of searches, getting collector notes, quite a few codes etc. Saw the total was at 500 so thought I'd check to see if I could redeem it.

Couldn't log in, then realised 'my' name wasn't on the redeem etc. drop down and that it was showing $s not £s. Took clearing cache / history to get into my account. (I clear cache every so often so now wonder if I've lost SB before to this strangers account, since I don't keep a tally when I get SB!) Back and forth with 'customer service' for 1 month, today they told me I can't have 2 accounts.

I do NOT and no one else in the house / with access to device I use SB on uses swagbucks. My Wifi / net is also secure. Just now I got told that there's been no deductions from my account... only told them lots of times my SB had gone into a strange acct.

rather than being placed into my account. They also told me to update 'my' e-mail security. When its their own security that's iffy seeing as I was somehow seeing / adding SB to some strangers account. My post on their US facebook posted earlier today has vanished, as has a members reply that she'd seen others with the same issue posting a while ago.

She said their posts vanished, so luckily I got a screenshot. I didn't think to grab my own first post / reply to the nice SB member who was trying to help.

I've removed full name of SB member and most of the strange account name. My own name is 5 letters and does not start with K nor end with r.

Review about: Swagbucks Account.

Reason of review: SB going into strange account - not fixed after 1 month..

Preferred solution: Let the company propose a solution.

I didn't like: Customer service.

Do You Have Something To Say ?

Write a review

Comments

Terms of Service
Post Comment
Cancel

You May Also Like